You are here:  » Cron.php problem

Active Forum Topics


Cron.php problem

Submitted by wesse249 on Wed, 2019-07-31 15:01 in

Hello,

When apllying my cron the fetching works well, but the the importing stops.

When importing from the backen everything works fine. Do yo maybe know what the problem can be?

I use the modifications from this node: https://www.pricetapestry.com/node/6299

Thank you Jan Roel

Submitted by support on Thu, 2019-08-01 09:18

Hello Jan,

HTTP invocation of cron.php is not ideal, it is really only intended for use if command line php is not available - if you have the Option 1 command available (/admin/ > Setup > CRON) switching to that would be the best option but if you do need to run a full cronjob over http, drop me an email and I'll forward an alternative version that fetches / imports one feed at a time and then re-loads the page to run the next job. It would still require that your web server allows an HTTP connection to keep-alive for the time taken to fetch / import your largest feed...

Cheers,
David.
--
PriceTapestry.com

Submitted by wesse249 on Thu, 2019-08-01 11:05

Hello David,

I have also setup a cron. This cron also not import the products. My other site is everything working okai with the cron and with the http invocation. So i was thinking maybe are the customizations causing the problem.

Cheers Jan Roel

Submitted by support on Thu, 2019-08-01 14:18

Hello Jan,

My apologies I accidentally replied in a different thread - after making the customizations does a manual import of a single feed from /admin/ home page work as expected?

Cheers,
David.
--
PriceTapestry.com

Submitted by wesse249 on Fri, 2019-08-02 07:39

Manual import of a single feed from works fine. Then i have no problem.

Cheers Jan Roel

Submitted by support on Fri, 2019-08-02 09:17

Hello Jan,

That's strange - so after cron.php has run, does the /admin/ home page show all feeds as modified but none are showing an imported date/time (so the Import buttons are all green)? Or do they show an imported date/time but all zero products?

Cheers,
David.
--
PriceTapestry.com

Submitted by wesse249 on Fri, 2019-08-02 10:10

Hallo David,

You can login {link saved}

All are modified and also imported but no products. When you click manual on import the products are imported. Could maybe the problem that there are only product imported with a from price (extra added field). Because i only product with a old / new price.

https://www.pricetapestry.com/node/6299

Cheers, Jan Roel

Submitted by support on Mon, 2019-08-05 10:03

Hello Jan,

Please can you email me includes/admin.php and scripts/cron.php from this installation and I'll check it out further for you...

Cheers,
David.
--
PriceTapestry.com