You are here:  » Feeds Unregistered Suddenly Now Cannot Seem to Register

Active Forum Topics


Feeds Unregistered Suddenly Now Cannot Seem to Register

Submitted by Stew on Tue, 2018-05-29 08:41 in

Hi David, hope all's going well,

Wondering if you can help our site {link saved} has been running fine for a long time and this weekend the feeds became unregistered, and we can't now seem to register.

We can get as far as this page: {link saved}

But when we click trial import we see a 500 error:

{link saved}

Any ideas what's going on?

Many Thanks,

Stew

Submitted by support on Tue, 2018-05-29 09:22

Hello Stew,

The reason for a 500 Internal Server Error is normally reported to the web server's error log - if you have access to that, run the registration process again until the error occurs and then check the log immediately afterwards and see if anything is reported. If there is a corresponding entry and you're not sure where the problem lies let me know what is logged and I'll check it out further with you.

It does point however to a MySQL issue. These don't generally cause a 500 error, it is more often a case of unable to connect (if MySQL server is down), or authentication issues which are reported by PHP however a 500 error can occur as a result of a timeout.

If you are able to, I would run a restart of the server as that might bring the database back-up; and also check the disk space on your server as if that was running low it can manifest in various ways such as this...

Cheers,
David.
--
PriceTapestry.com

Submitted by Stew on Wed, 2018-05-30 15:57

Hi David, many thanks for your help there, I went back to the host and tried the database update, they then said that php version 5.5 was set for the domain, so they've changed to php5.6.

The feeds now register, but something odd is happening, please see:

{link saved}

If I click "de-register" next to a field, as this is an old feed, the feed won't deregister - I've deleted this product feed file via FTP also.

And if I try and register an existing feed a feed with no name appears in the table - which I can deregister....

Do you think the database needs repairing or something else maybe?

Im trying to get rid of one feed - as these products are now out of date and also update a new feed - but can't seem to do either....

Many Thanks,

Stew

Submitted by support on Thu, 2018-05-31 08:44

Hello Stew,

Please could you email me includes/admin.php from this installation (for reference), and I'll forward a clean-up script to restore integrity between the products and feeds tables, it does look like they have become inconsistent following the database issues...

Thanks,
David.
--
PriceTapestry.com